Angular support broken after updating to 2018.3

Title. Only html code is recognized in templates, not any angular or project specific tags, attributes or directives, can't bind to html attributes either ( [id]="*" is not allowed), no autocomplete or suggestions working either, string interpolation showing as plain text as well. Issue appeared after updating to 2018.3 without making any changes to settings. Google wasn't helpful, several people in the office are experiencing same issue, nobody knows how to fix it. Help please.

45 comments
Comment actions Permalink

Do you have AngularJS plugin enabled? Please provide your idea.log.

Also, can you recreate the issue using a new Angular CLI project?

0
Comment actions Permalink

I do have the AngularJS plugin installed. I am not sure if I would be permitted by my company to share a log with a 3rd party. I don't really have time to be testing, so I chose to downgrade to 2018.2 to continue my work.

0
Comment actions Permalink

Any update on this issue? I tried removing the "excluded" label on the node_modules folder and just the angular folder inside but no workie. Totally borked the angular projects with this update. Downgrading to 2018.2.x until this is addressed.

Having the same problem with:

IntelliJ IDEA 2018.3.2 (Ultimate Edition)
Build #IU-183.4886.37, built on December 17, 2018
-- license redacted --
JRE: 1.8.0_152-release-1343-b26 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.2

0
Comment actions Permalink

@Dmitry, https://youtrack.jetbrains.com/issue/WEB-36065 is fixed in 3.2, so your issue is different.

Do you have AngularJS plugin installed and enabled? Can you recreate the issue in a new Angular Cli project?

We need a project that shows up the problem to see what's wrong. You can remove all proprietary stuff from it, leaving just a pair of dummy components, but your configuration and .idea folder has to be there, and you should be able to recreate the issue using it

0
Comment actions Permalink

Same issue here:

IntelliJ IDEA 2018.3.3 (Ultimate Edition)
Build #IU-183.5153.38, built on January 9, 2019
JRE: 1.8.0_152-release-1343-b26 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.2

0
Comment actions Permalink

I just created a blank new project with File -> New Project -> Static Web -> Angular CLI and the problem is the same.

"@angular/cli": "~7.2.1",

Please download the newly created zipped project (71MB) here http://bit.ly/2QBqFBC

0
Comment actions Permalink

@Liefra Everything looks good to me when using your project (#IU-183.5153.38, AngularJS plugin 183.5153.38).

What problem have you faced namely? Please provide screenshots illustrating it and your idea.log

0
Comment actions Permalink

Problem 1): No syntax checking and code completion in Typescript file

 

Problem 2) No detection of Angular tags and code completion in template files

 

0
Comment actions Permalink

works fine for me:

 

 

Please try invalidating caches (File | Invalidate caches, Invalidate and Restart); if the issue persists, please send your idea.log (don't paste it here, upload it to some file server and provide a link)

0
Comment actions Permalink

Invalidating caches doesn't solve the issue.

Find my idea.log here: http://bit.ly/2CfZya9

 

0
Comment actions Permalink

I can see lots of error thrown on nearly each action. Looks as if the installation is somehow broken. Unfortunately only the 'tail' of the log is there, more info can (probably) be obtained from other idea.log* files located in the same folder.

I'd suggest re-installing from scratch. If it doesn't help, try removing IDEA plugins, configuration and caches:

rm -rf "~/Library/Preferences/IntelliJIdea2018.3"
rm -rf "~/Library/Caches/IntelliJIdea2018.3"
rm -rf "~/Library/Application Support/IntelliJIdea2018.3"
rm -rf "~/Library/Logs/IntelliJIdea2018.3"

0
Comment actions Permalink

Disabling of some custom plugins resolved my issue. I disabled the plugins "Azure Toolkit for IntelliJ", "R Language Support" and "Angular 2 TypeScript Live Templates"

1
Comment actions Permalink

Thanks Liefra, I disable the "Azure Toolkit for IntelliJ" plugin and it resolves the problem.

1
Comment actions Permalink

I have solve the issue by enable angular plugin in file->settings->plugins.

after enable the angular plugin restart the editor.

1

Please sign in to leave a comment.