Angular support broken after updating to 2018.3

Title. Only html code is recognized in templates, not any angular or project specific tags, attributes or directives, can't bind to html attributes either ( [id]="*" is not allowed), no autocomplete or suggestions working either, string interpolation showing as plain text as well. Issue appeared after updating to 2018.3 without making any changes to settings. Google wasn't helpful, several people in the office are experiencing same issue, nobody knows how to fix it. Help please.

51 comments
Comment actions Permalink

Hello,

here is what i get on a random .html in my project : 

0
Comment actions Permalink

I'm having the same issue.

IntelliJ IDEA 2018.3.1 (Ultimate Edition)
Build #IU-183.4588.61, built on December 4, 2018
JRE: 1.8.0_152-release-1343-b16 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.9.124-0.1.ac.198.73.329.metal1.x86_64

@angular directory is NOT excluded

HTML file is showing as HTML type

0
Comment actions Permalink

Do you have AngularJS plugin enabled? Please provide your idea.log.

Also, can you recreate the issue using a new Angular CLI project?

0
Comment actions Permalink

I do have the AngularJS plugin installed. I am not sure if I would be permitted by my company to share a log with a 3rd party. I don't really have time to be testing, so I chose to downgrade to 2018.2 to continue my work.

0
Comment actions Permalink

Any update on this issue? I tried removing the "excluded" label on the node_modules folder and just the angular folder inside but no workie. Totally borked the angular projects with this update. Downgrading to 2018.2.x until this is addressed.

Having the same problem with:

IntelliJ IDEA 2018.3.2 (Ultimate Edition)
Build #IU-183.4886.37, built on December 17, 2018
-- license redacted --
JRE: 1.8.0_152-release-1343-b26 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.2

0
Comment actions Permalink

@Dmitry, https://youtrack.jetbrains.com/issue/WEB-36065 is fixed in 3.2, so your issue is different.

Do you have AngularJS plugin installed and enabled? Can you recreate the issue in a new Angular Cli project?

We need a project that shows up the problem to see what's wrong. You can remove all proprietary stuff from it, leaving just a pair of dummy components, but your configuration and .idea folder has to be there, and you should be able to recreate the issue using it

0
Comment actions Permalink

Same issue here:

IntelliJ IDEA 2018.3.3 (Ultimate Edition)
Build #IU-183.5153.38, built on January 9, 2019
JRE: 1.8.0_152-release-1343-b26 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.2

0
Comment actions Permalink

I just created a blank new project with File -> New Project -> Static Web -> Angular CLI and the problem is the same.

"@angular/cli": "~7.2.1",

Please download the newly created zipped project (71MB) here http://bit.ly/2QBqFBC

0
Comment actions Permalink

@Liefra Everything looks good to me when using your project (#IU-183.5153.38, AngularJS plugin 183.5153.38).

What problem have you faced namely? Please provide screenshots illustrating it and your idea.log

0
Comment actions Permalink

Problem 1): No syntax checking and code completion in Typescript file

 

Problem 2) No detection of Angular tags and code completion in template files

 

0
Comment actions Permalink

works fine for me:

 

 

Please try invalidating caches (File | Invalidate caches, Invalidate and Restart); if the issue persists, please send your idea.log (don't paste it here, upload it to some file server and provide a link)

0
Comment actions Permalink

Invalidating caches doesn't solve the issue.

Find my idea.log here: http://bit.ly/2CfZya9

 

0
Comment actions Permalink

I can see lots of error thrown on nearly each action. Looks as if the installation is somehow broken. Unfortunately only the 'tail' of the log is there, more info can (probably) be obtained from other idea.log* files located in the same folder.

I'd suggest re-installing from scratch. If it doesn't help, try removing IDEA plugins, configuration and caches:

rm -rf "~/Library/Preferences/IntelliJIdea2018.3"
rm -rf "~/Library/Caches/IntelliJIdea2018.3"
rm -rf "~/Library/Application Support/IntelliJIdea2018.3"
rm -rf "~/Library/Logs/IntelliJIdea2018.3"

0
Comment actions Permalink

for example. Angular plugin doesn't work

0
Comment actions Permalink

can you reproduce the issue in a new Angular CLI project? If yes, something must be wrong the the installation/configuration (missing/broken/conflicting plugins, etc.). If not, it must be a problem with your project setup

Is @angular/core node module installed in your project and included in indexing? Please select your .html file in Project tool window and hit F1 (View | Quick documentation) - what docs are shown? Please share a screenshot of documentation popup and your idea.log (Help | Show log in ...).

 

0
Comment actions Permalink

BTW, did you face the issue after upgrading to 2018.3? If you are using a different IDE version, what's the reason for commenting in this thread?

0
Comment actions Permalink

I was able to solve the problem for me. It required two things. First, only dependencies listed in package.json are considered (so I added all the angular dependencies there). Second, the node_modules folder needs to show “library root” beside it. The second thing is not straightforward to fix. I had to un-exclude the folder (unmarked) and also in one project I had node_modules as a content root in project structure and I had to delete that path. Afterwards, I invalidated the caches and restarted and the template highlighting began to work again.

0
Comment actions Permalink

please make sure that node_modules/@angular folder and subfolders are not marked excluded: Angular support requires including @angular packages in index

Please provide screenshot of the Project tree view with node_modules/@angular folder expanded, so that I can see what it looks like. Also, did you try invalidating caches?

-1

Please sign in to leave a comment.