Disable HTML JSX attributes quotes/braces behaviour

Greetings,

The above behaviour has existed in WebStorm for a while now and I've never been able to disable the above shown HTML JSX attribute autocompletion in regards to auto adding either Quotes or Braces.

I spend half my time replacing {} with "" and vice versa and would love to just disable this behavior - i.e. disable WebStorm from adding either Braces or Quotes on JSX attributes.

I've tried to disable this in Settings -> Code Style -> HTML -> Other -> Add for JSX attributes but none of the settings there make any difference.

Am I looking at the wrong setting? How do I disable this? 

Please sign in to leave a comment.