How to add --add-exports?

It show me add "--add-exports='.....' to module " everytime when I reopen the idea.

How to add it forever?

 

 

 

 

3 comments
Comment actions Permalink

Hello, do you have empty Override parameters per module (in Preferences | Build, Execution, Deployment | Compiler | Java Compiler) after reopening the project, please confirm? What IDEA version do you use?

0
Comment actions Permalink

 

 

I try to add 

-add-exports=java.base/jdk.internal.misc=ALL-UNNAMED

to here, reopening the preject, It doesn't work.

Clean the add parameters doesn't work ,too.


 

0
Comment actions Permalink

Please clarify, after adding a compilation option to module you close the project, open it, and there is no added option in Override compiler parameters table? Or option is presented in table, but IDEA still asks to add option and highlights import in code Editor? If possible please provide idea.log and sample project where the issue is reproduced. Thanks

0

Please sign in to leave a comment.