Node.js debugging in Intellij 2018.3 not working

Hello, I updated to version 2018.3 couple of days ago and Node.js debugging stopped working since then. I can set a breakpoint but the code execution does not stop there anymore. Is it a known problem?



Ewgenij Sokolovski

Comment actions Permalink

What Node.js version do you use? please can you check if disabling js.debugger.use.node.options key in Registry ( Help | Find action, type Registry to locate it) makes things any better?

Comment actions Permalink

Hello, it's Node 8.10.0. 


After I disabled


it started to work again. According to the description of the option, it uses NODES_OPTIONS environmental variable instead of the --inspect flag. But this variable is empty in my setup.


Please sign in to leave a comment.