Validating debugger configuration : Specified URL is not reachable (404)

Hello,

My setup :

Host : Windows 10
VM : Debian 9 (stretch) running Nginx
PhpStorm working directory is a mounted drive (samba) named V: pointing to /var/www in my VM
I configured a remote interpreter via SSH Credentials, and PHP executable set as /usr/bin/php

 

Validation tool :

Path to create script : V:\myproject\pub (because this is a Magento 2 project, web root is pub)
Url to validation script : https://local.myproject.fr (checked in browser, displays my homepage)

When trying to run the debug validation, I get this error : "Specified URL is not reachable, caused by: 'Request failed with status code 404'"

I tried other variations with php interpreter (deployment configuration using + SFTP deployment server, SSH Credentials..)
I also tried different variations of deployment servers (mounted folder, SFTP) used directly by validation tool via "Remote Web Server"

I think I have read too much tutorials and forum posts, and now I'm totally confused... I cannot figure out what is preventing PhpStorm from reaching the specified url...

Can somebody help me ?

 

Thanks by advance !

6 comments

Please use this article to troubleshoot this: https://www.jetbrains.com/help/phpstorm/validating-the-configuration-of-the-debugging-engine.html & post screenshots of your results if that doesn't help

 

0

Hello Dmitry, and thank you for taking the time.

Well, I was already using this article to help me in this process and it didn't help me. I think I'm just missing the real issue here and I need help to spot it.

Here are the screenshots :

 

Thank you by advance !

0

Anything missing for someone to help me ? I'm still stuck with this issue :(

0

Sorry for leaving you without the response.

I was wondering if it is possible to try a short test.

The idea is simple -- place any test html/php file in "Folder" of your deployment server and try to open it via URL like "https://local.myproject.fr/file.html". 

Another option is to create a file in the root of the project and try deploying it to the Web Server with "Deployment > Upload" option.

Also, a short remark -- did you try using "http" instead of "https"?

0

Hi,

I 've got the same problem. Is there any solution?

0

Hello,

Did you try recommendations from this thread already?

0

Please sign in to leave a comment.