Typing Thai fonts incorrectly in the search box is square character.

Answered

Typing Thai fonts incorrectly in the search box is square character.

7 comments
Comment actions Permalink

Try changing the IDE appearance font to the one that can display Thai glyphs: https://stackoverflow.com/a/46388106/104891.

Or use 2018.3.1 (or later) from http://www.jetbrains.com/idea/download/index.html and add

-Dide.find.use.editor.font=true

in Help | Edit Custom VM Options and restart the IDE.

0
Comment actions Permalink

your solution does't solved my problem.

0
Comment actions Permalink

Did you try both of them? What IDE version do you use?

Which font did you set for IDE UI and for the Editor?

0
Comment actions Permalink

With your current settings this font will be used for Find field:

Make sure it can display Thai glyphs.

0
Comment actions Permalink

In "Color Scheme Font",  can display Thai, but search box is not.

0
Comment actions Permalink

Please show the screenshot of the editor with the Thai glyphs. Did you restart IDE after editing .vmoptions file?

According to https://youtrack.jetbrains.com/issue/IDEA-106651, this feature should work since 2018.3.1.

Does it help if you change the -Dide.find.use.editor.font=true to -Dide.find.use.editor.font=false and restart IDE again?

0

Please sign in to leave a comment.