Trying to debug javascript in IDEA 2018.2 - doesn't fully connect?

I have a Tomcat server that I start via a Tomcat Server Run Configuration - its Application Server type is Tomcat Server, its HTTP port is 8321.

I run my Typescript app via a JavaScript Debug Run Configuration whose URL is  http://localhost:8321/blahblahblah

For ages, I've been debugging my app via the Chrome debugger. However, last Friday, when I was running IDEA 2018.1.2, someone from another team commented to me that they'd been successful using IDEA to debug their Typescript. So I tried it, and it worked great. Instead of running the JS Debug Run Configuration, I hit "debug", and it connected nicely to IDEA - the IDEA Debug Window's console showed my JS console, my breakpoints were hit, everything was happy.

Yesterday, I decided to update to the version of IDEA that everyone else on my team is using - IDEA 2018.2.2. I hit "debug" on my Run Configuration, the browser window started, and I got this:

The browser window was unresponsive. After several minutes, the IDEA Debug Window Console started showing me messages, and the browser window became responsive again, but none of my breakpoints are being hit.

I have the JavaScript Debugger plugin installed in IDEA. I have the JetBrains IDEA Support extension in Chrome, although my understanding is that I don't actually need it anymore unless I want Live Editing (which I don't).

What's going on? What changed between 2018.1.2 and 2018.2?

 

 

6 comments

please try updating IDEA to the most recent version (2018.3.2) - does the issue persist?

0

The problem was there in 2018.3.2 as well. I downgraded from 2018.3.2 back to 2018.2 because of this and other issues in 2018.3.2 (https://youtrack.jetbrains.com/issue/IDEA-204416), and found that this is there in 2018.2 as well.

0

Do you have Live edit plugin installed and enabled? It can be related to https://youtrack.jetbrains.com/issue/WEB-36060...

If it's not the case, seems that I would need your project to see what's going on:(

0

I had the Live Edit plugin installed, but I just uninstalled it and tried again, with the same result.

0

Can you share a project we can use to recreate the issue?

0

Unfortunately, I can't. My company has extremely strict rules about code sharing. I'm not sure I could even put together a toy project and share it :-(

0

Please sign in to leave a comment.