PhpStorm add spaces everywhere

Hello,

I face a little weird problem - not insurmountable but very annoying anyway : each copy pasted that I do, or as soon as I do some automatic actions with PhpStorm, the IDE adds a lot of space everywhere: between the ( and the ' , between the ( everything is short, it is very unpleasant.

Do you have any idea about solving this "problem"?

Thanks for help. 

Blaise

2 comments

Hi there,

Right now it sounds like your code gets auto-formatted to your Code Style.

1) You may configure your Code Style for PHP at "Settings/Preferences | Editor | Code Style | PHP"

2) "Settings/Preferences | Editor | General | Smart Keys | Reformat on paste" -- set it to "None"

0

Hi, 

Oh, thanks. 

The configuration of my Code Style for PHP being in question.

Blaise 

0

Please sign in to leave a comment.