HTML not formatting?

<tr bgcolor="#66CCFF">
<td><strong>Totals</strong> (29 airlines)</td>

<td align="right"><strong>90180</strong></td>

<td align="right"><strong>88945</strong></td>

<td align="right"><strong>89907</strong></td>

<td align="right"><strong>76002</strong></td>

<td align="right"><strong>77354</strong></td>

<td align="right"><strong>72112</strong></td>

<td align="right"><strong>67718</strong></td>


<td align="right"><strong>562218</strong></td>
</tr>

I hit Ctrl+Shift+F to format and it says:


Isn't it supposed to remove the extraneous empty lines as part of the formatting?

5 comments

Please attach a screenshot of your Preferences | Editor | Code Style | HTML

0

Default value for Keep blank lines: in Settings | Editor | Code Style | HTML | Other is 2, that's why code is not changed. Try setting it to 0 - does it help?

0

Dmitry, screenshot of my HTML code style settings below:

 

0

Elena, I think I will keep that setting to 2 lines; I guess PHPStorm won't distinguish between major block tags like div or ul and minor ones like li or td etc when it comes to empty lines.

0

It has a single option for empty lines. And, indeed, it doesn't distinguish between 'major' and 'minor' tags

0

Please sign in to leave a comment.