Remove `run anything` keyboard shortcut

Hi, 

I was wondering if it's possible to remove double ctrl shortcut (which execute run anything command).

I use double ctrl as a global system shortcut (to show terminal) and it is kinda annoying in PhpStorm.

10 comments
Comment actions Permalink

Not at the moment, but you will be able to disable the shortcut in the upcoming release: https://youtrack.jetbrains.com/issue/IDEA-197444

It'd take place in the middle of the next week.

0
Comment actions Permalink

Is this fix available already?

1
Comment actions Permalink

Yes, it should

1
Comment actions Permalink

It is already available in IDE's build > 183.5065.

2
Comment actions Permalink

I found a workaround that works in the following edition:  assign any other keyboard shortcut to "Run Anything" (I chose ^+#R, which I won't hit by accident.)

IntelliJ IDEA 2019.1.4 (Community Edition)
Build #IC-191.8026.42, built on July 30, 2019
JRE: 11.0.2+9-b159.64 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.6

1
Comment actions Permalink

Nothing is set as a shortcut but it still shows up when I double click `ctrl` by accident

PhpStorm 2019.3.3
Build #PS-193.6494.47, built on February 12, 2020

2
Comment actions Permalink

That is weird design, but apparently you need to assign some shortcut to the action in order to make Run Anything stop respond on double Ctrl.

4
Comment actions Permalink

Fast-forward, this is still the same behavior on Phpstorm 2021.3.1. 

0
Comment actions Permalink

Hi there,

Settings (Preferences on macOS) | Advanced Settings | Disable double modifier key shortcuts

1

Please sign in to leave a comment.