Raspberry Pi - Upgraded 2017 CE to 2018 - Now won't run...

Hi - I had previously installed PyCharm 2017 CE on a RPi 3...it was working great.

I finally succumbed to the "Updated Version Available" message...I downloaded and installed according to the Linux instructions on the Jetbrains site...perhaps I did something wrong?

Now when I try to open PyCharm from the RPi pulldown menu ("Programming") I get the message:

"Invalid desktop entry file: '/home/pi/.local/share/applications/jetbrains-pycharm-ce.desktop'"

...and I can't run pycharm.sh from the /opt directory where I was instructed to install PyCharm CE.

How can I uninstall what I just installed, and properly install PyCharm CE? I'm not a Linux expert, but had it running back in 2017 just fine...

3 comments

I re-installed according to the instructions. Here's the error message I get:

pi@raspberrypi:/opt/pycharm-community-2018.3.2/bin $ ./pycharm.shException in thread "main" java.lang.UnsupportedClassVersionError: com/intellij/idea/Main : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:808)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:443)
at java.net.URLClassLoader.access$100(URLClassLoader.java:65)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.net.URLClassLoader$1.run(URLClassLoader.java:349)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:348)
at java.lang.ClassLoader.loadClass(ClassLoader.java:430)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:323)
at java.lang.ClassLoader.loadClass(ClassLoader.java:363)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
pi@raspberrypi:/opt/pycharm-community-2018.3.2/bin $ 

Any help would be appreciated.... Thanks...

0

Have you tried downloading the latest version from https://www.jetbrains.com/pycharm/download/#section=linux and installing into a new empty directory? 

Also, RPi3 CPU 64 or 32 bit? If I'm not mistaken, they're all 32 bit, but PyCharm for Linux package contains 64 bit JRE, so you might need to install 32 bit JRE manually and select it according to https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

0

Thanks for the response. The 64/32 bit issue might be the problem. I hadn't thought of that. The upgrade screen that came up on Chromium pointed me to what I now suspect was a 64 bit version which I downloaded and installed. Iit ran the splash screen ok, then hung...never to return.

Based on the error log above I was thinking it was an issue with the Java JDK...but reinstalling that caused even more problems.

So I finally gave up on upgrading PyCharm. I started over with a clean RPi OS, added the main things I needed, and then downloaded and installed the PyCharm .tar file as I had done in my initial message. I will add that, based on your mention of 32 vs. 64 bit OS, this time the Chromium install page took me to a place that seemed to recognize I was running a Pi. I don't think the upgrade page recognized that, so it may be that I downloaded the incorrect version for the upgrade.

So to summarize I couldn't upgrade PyCharmCE from 2017 to 2018 by following the upgrade link provided by the PyCharm upgrade notice, but starting over with a clean OS and 2018 .tar file worked. Sometimes that's just what you gotta do...

0

Please sign in to leave a comment.