Chrome Debugger (v2.0.9) broken with any version of Webstorm.

Tried uninstall/reinstall Chrome, no change. When I do lsof -i on the port I've been using (:65432, but also have used canonical :63342), the result:

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
webstorm    7218 ***    70u IPv4    ***          0t0           TCP     localhost:65432->localhost:58319 (ESTABLISHED)
webstorm    7218 ***    72u IPv4    ***          0t0           TCP     localhost:65432 (LISTEN)
webstorm    7218 ***    73u IPv4    ***          0t0           TCP     localhost:65432->localhost:58324 (ESTABLISHED)
Google        7484 ***    192u IPv4  ***          0t0           TCP     localhost:58324->localhost:65432 (ESTABLISHED)
Google        7484 ***    204u IPv4   ***         0t0           TCP     localhost:58319->localhost:65432 (ESTABLISHED)

The issue manifests itself as the inability to right-click and debug a webpage. However, the extension says "Connected to Webstorm. Has access to this website", when I hover the right-hand corner jetbrains ide support button. 

Any help is appreciated.

5 comments
Comment actions Permalink

Can you provide Chrome extension console content as text (see http://confluence.jetbrains.com/display/WI/LiveEdit, How do I know what's wrong? for details)? Can be https://youtrack.jetbrains.com/issue/WEB-36675

BTW, can you check if debugger works without extension? Try disabling Use JetBrains IDE Support extension for debugging and Live Edit in Settings | Build, Execution, Deployment | Debugger | Live Edit - does it help?

0
Comment actions Permalink

Hi @Elena Pogorelova! Thanks so much for responding, I really appreciate the quick response of community support here.

When I visit chrome extensions and check developer mode, under intellij ide support, I get two options:

  • background page (iframe)
  • background page

selecting either generates a new option, but if I go to the console page generated, the log output says:

 

bootstrap.kt:95 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
$fa @ bootstrap.kt:95
value @ bootstrap.kt:148
$f2 @ bootstrap.kt:46
$f0 @ options.kt:12
$f0 @ chrome-jb.kt:38
logging.kt:43 Ready to load system latest for WebStorm 2018.3.2 (127.0.0.1:63342)
_generated_background_page.html:1 Error handling response: TypeError: This event does not support filters
at Object.value (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/latest/kotlin-output/jb-chrome-ext-api.js:31:15)
at Object.value (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/latest/kotlin-output/jb-chrome-ext-api.js:78:30)
at Object.value (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/latest/kotlin-output/jb-chrome-ext-api.js:88:30)
at Object.$f2 (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/kotlin-output/browser-ext-bootstrap.js:26:66)
at $f0 (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/latest/kotlin-output/chrome-ext-options.js:8:7)
at $f0 (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/latest/kotlin-output/jb-chrome-ext-api.js:16:7)
logging.kt:43 System latest loaded for WebStorm 2018.3.2 (127.0.0.1:63342)
chrome-jb.kt:50 Uncaught TypeError: This event does not support filters
at Object.value (chrome-jb.kt:50)
at Object.value (chrome-jb.kt:102)
at $f8 (chrome.kt:42)
at Object.$f1 (socket.kt:64)
value @ chrome-jb.kt:50
value @ chrome-jb.kt:102
$f8 @ chrome.kt:42
$f1 @ socket.kt:64
1
Comment actions Permalink

Disabling Live Edit had no effect on the above output.

0
Comment actions Permalink

Thanks! this is indeed https://youtrack.jetbrains.com/issue/WEB-36675, please follow it for updates.

For now, I'd suggest turning Use JetBrains IDE Support extension for debugging and Live Edit off in Settings | Build, Execution, Deployment | Debugger | Live Edit 

1
Comment actions Permalink

@Elena Pogorelova, will do. Let's mark this as a duplicate.

0

Please sign in to leave a comment.