PyCharm Does Not Start Flow Service

I'm currently running PyCharm 2018.3.2 on macOS 10.14.2.

The flow service refuses to start. PyCharm does not appear to even attempt to start the flow service, as there's no flow tab at the bottom of the window.

I've attached my JS language settings in PyCharm. Is there something I'm missing?

9 comments

Do you have .flowconfig file in the project root dir? also, did you add 

// @flow

annotation to your .js files?

0

Hi Elena. Thanks for the reply.

The JS files do have a `@flow` annotation at the top just like you describe. However, the annotation displays the following warning.

Here's the flowconfig file.

 

```

[ignore]

[include]

[libs]
node_modules/iflow-jquery/index.js.flow
regiondb/common/webpack/flow-interfaces/
regiondb/common/webpack/flow-typed/

[lints]

[options]
module.name_mapper='^react-native$' -> 'react-native-web'
suppress_comment=\\(.\\|\n\\)*\\$FlowExpectedError

[strict]

```

 

I also have a Mac with a fresh install of 10.13.6, PyCharm 2018.3.2 and the same JS language settings and it's exhibiting the same issue, so I don't think this issue is specific to macOS 10.14.

0

Warning indicates that javascript language version is not set to `Flow`... weird. Can you share your project .idea folder? Is it the only project you have opened?

0

Hi Elena. I've figured out the issue. When setting up my project in PyCharm, I accidentally told PyCharm to open a folder in the project instead of having it open the project folder itself. This created a second .idea folder in the project. After deleting this second .idea folder, flow works as expected now. I've replicated the fix on the secondary 10.13.6 Mac.

I hope my explanation makes sense. I can provide more clarification if needed.

This does seem like a bug though. A stray .idea folder probably shouldn't cause Flow support to stop working.

Thank you for your help. I don't think I would have thought about deleting the second .idea folder if you hadn't asked about sharing the project's main .idea folder.

0

Inner .idea folder doesn't normally do any harm - it's just ignored... Only the .idea folder located in the project root is respected, and only those properties that are set in it are used as project prereferences. Exact steps to recreate the issue would be helpful

0

For what its worth:  I am seeing a very similar issue with 2019.2 on a mac ox 10.12.6 (16G29) .  Trying to debug it now.  Kind of frustrating!  It was working, then it suddenly stopped.  For another person on my team as well.  His stopped maybe a week ago. Flow  just reports "Service Not started".

 

Any help would be appreciated.  

0

in my workspace.xml i have this:

 

<component name="JsFlowSettings">
<service-enabled>true</service-enabled>
<exe-path>/usr/local/bin/flow</exe-path>
<other-services-enabled>true</other-services-enabled>
<auto-save>false</auto-save>
</component>

And i might add i've tried both a local version of flow and the global. the global used to work.


0

i just tried changing the .idea folder to  idea.bak and creating a new react project using the same directory. No love.  Flow does not show up as an option in the tools menu.  

0

open a .js file with

// @flow

annotation in the editor, edit and save it - does the Flow tool window open?

0

Please sign in to leave a comment.