Database Data Source Properties dialog box doesn't open

I just upgraded from phpstorm 2018.1 to 2018.3.3. Pressing the Data Source Properties box doesn't open the dialog to edit my connection. Adding a new data source also doesn't open that dialog. (At one point it did manage to open when adding a new source, but I can't get it to do it again.) I have already tried "invalidating caches and restarting". What else is there to do?

Edit: I forgot to mention I'm on Mac OSx 10.14.2 


It looks like many things are broken as well, like using "save as..." for files, etc. Dialog boxes just aren't opening.

What's the proper solution without wiping all my settings thus having to lose all my key bindings and personal settings?

Edit: I backed up and then deleted my ~/Library/Preferences/PhpStorm2018.3 directory, then started phpstorm WITHOUT importing settings from old version of phpstorm to start from scratch. The dialogs are still not opening. I'm at a loss now.


Found the culprit! There was a very old version of Material Theme UI installed that for some reason was failing to update. I removed it and reinstalled the latest theme and everything is working now.


Thanks for the update.

Glad to know that you have managed to find the solution, pretty sure it will be useful for other users as well.


Please sign in to leave a comment.