What happened to the Deployment tool??

I recently upgraded my Goland IDE but prior to this there was an awesome tool/plugin that I used constantly that I can't seem to find now.  

You could access it from Settings > Build, Execution, Deployment.  

It would allow you to configure servers that you could deploy code to.  You could access the servers from their IPs and use either usernames and passwords or ssh keys.  You could specify a deploy path per project.  

This allowed you to right click a directory or file in your project, select a server to deploy it to, and deploy it.  Probably not a good practice for production, but amazing for development and testing.  

I used this feature constantly, and since upgrading my Goland I can't find it anywhere.  I think it was originally a plugin but now that I'm searching for the same plugin again I can't seem to find it.  

Can anyone help?  

0
6 comments

Please go to Settings/Preferences | Plugins | Installed and search for "Remote Hosts Access". Then click on the plugin and. if the button to "Disable" the plugin has an arrow pointing down on the right side of it, then click the arrow and select "Uninstall". If this doesn't solve the issue, please let me know.

0

Thanks Florin.  It has a minus sign and it says "Incompatible with the current Goland version."  

Do you know when this plugin will be upgraded?  Alternatively, do you know how I can downgrade my Goland to the most recent version compatible with this plugin and how I'd figure out which version I need?  

0

Can you please attach a screenshot? You should be able to uninstall the currently installed version which would restore the functionality as the plugin is bundled with the IDE so everything should work out of the box without the need of manual upgrades/intervention.

0

 

Sure, here is a screenshot.  My current Goland version is 2018.3.2.  I also tried this on version 2018.3.3 and had the same issue, before rolling back to 2018.3.2.  

0

Florin,
It looks like the most recent version that is compatible with this plugin is this one:   

GoLand 2018.1.7
Build #GO-181.5540.31, built on November 13, 2018

So I've rolled back to that one for now.  But it would be great if the plugin itself could be updated so I could also have the new version of GoLand.  

Thanks for your help!

0

Since GoLand 2018.3 Web deployment plugin is bundled into IDE.

To make it work just delete your custom version via Settings | Plugins page.

UPD: Actually, Florin already said you to do this. Have you tried?

0

Please sign in to leave a comment.