YAML completion contributor

Answered

Hey,

I have a YAML completion contributor for Swagger (https://github.com/zalando/intellij-swagger/blob/master/src/main/resources/META-INF/plugin.xml#L26). It does not play well with the YAML plugin completion contributor (https://github.com/JetBrains/intellij-community/blob/master/plugins/yaml/resources/META-INF/plugin.xml#L39). It seems that the `YamlJsonSchemaCompletionContributor` is always executed first and the custom Swagger completions are never executed.

I have tried to set the order to "first" and "before YamlJsonSchemaCompletionContributor" without success. What are my options here? :)

Best,

Sebastian

2 comments
Comment actions Permalink

Hello Sebastian,

Sorry for an unexpected API change.

You have two options, I'm not sure if the first one works, but you may try it.

1) try using both 'first' and 'before'

order="first, before YamlJsonSchemaCompletionContributor"

2) implement a JsonSchemaCatalogExclusion component, so that JSON schema downloading will be suppressed for specified files, and your provider will become active again. This will definitely work.

1
Comment actions Permalink

Thank you for the suggestions Anton. I can confirm that implementing a `JsonSchemaCatalogExclusion` indeed did the trick.

0

Please sign in to leave a comment.