Appcode can't resolve any type after adding a new Cocoapod

Answered

We have run into an issue where Appcode can't resolve any type in the editor. Everything in NSObject is listed as not visible. We have tried to invalidate the caches and restart and even reinstalling without any luck. Everything still builds fine and Xcode doesn't seem to have any trouble finding the symbols.

This started happening after we added the "Charts" cocoapod to our project (or because of another pod updating when we added charts). If we checkout the commit before we did this update then everything resolves fine.

Any suggestions on what we can try to fix the problem?

Thanks!

Raj

 

 

 

 

4 comments
Official comment

Looks like a known issue: https://youtrack.jetbrains.com/issue/OC-18010

Please try to build your project from AppCode for a device once, and then reopen your project.

Thank you so much for your quick reply! The workaround fixed the problem.

0

Hi again,

So we updated to AppCode 2018.3.4 which looks like it contained a fix for this issue but we are still having trouble with NSString. We've tried building to a device and invalidating the caches without any luck

 

0

Issue is fixed in the 2019.1 EAP build 

0

Please sign in to leave a comment.