Constant "Scanning files to index..."


Ever since 2018.3.2, I am constantly getting the "Scanning files to index..." process. This happens after every save or build process. It runs for a really long time and blocks almost all of my operations from file search to basic navigations. Sometimes opening and closing the Settings window pauses or terminates the indexing process, which allows me to continue working again.


I have to roll back to 2018.3.1, which works fine. I am on a windows machine with VMWare. In the vm is Linux which hosts IntelliJ. My project uses Java 6 and Git. My computer has 32 gigs of RAM with 8 allocated to the VM with 4 core processors.


I apologize for not being clear in my original message. What I mean by "Ever since 2018.3.2..." is that I have had this problem from the most current version 2018.3.4 all the way back 2018.3.2.


What specifically do you need from the logs? The development machine is in an isolated network and I can't transfer the logs unless I manually type it here. What I do see in the idea.log is a lot of:

project roots have changed

Unindexed files update canceled

Pushing properties took 23ms; general respnsiveness: ok; EDT responsivesness: sluggish

Unindexed files update canceled


This happens over and over in the logs.


Does it happen with any project? What third-party plug-ins do you have installed?

Does it occur with 2019.1 EAP?

Does your build process change files under the source roots or any libraries? is the proper place for such bug reports. You can make your issue private to share sensitive data.

You can also submit a private ticket to support at .

I don't think public forum is the best way to get it resolved in this specific case. It would be also hard to analyze the issue without all the logs attached.


Plug-ins installed:

CheckStyle-IDEA, CodeGlance, Eclipse Code Formatter, IDEA Restart, and Springirun


I have not tried 2019.1 EAP. The build process involves me running an ANT script that generate files in the BUILD directory under the root path. The BUILD folder is marked as "excluded" if that affects anything. The "Scanning files to index..." occurs when I perform a CTRL+S or version control "refresh", not during the ANT build.


I will try to aggregate the needed logs and submit a report in the next day or so unless a solution comes up beforehand.


Thanks for the details.

These issues can be related:

Thread dumps would help to confirm if it's the same problem or not.


I have this problem after upgrading to this version

IntelliJ IDEA 2019.1.1 (Ultimate Edition)
Build #IU-191.6707.61, built on April 16, 2019
Windows 10 10.0

It is indexing and re-indexing python libraries over and over again.


Please submit a ticket to support via and attach the logs/thread dumps.


... and it's indexing the Python libraries themselves over and over, not my project files.  The IDE's pretty much unusable---I can pause this but I can't see any way to shut it off.



I tried invalidating caches and restarting, and I tried reimporting the project from scratch (i.e. without any .iml files or .idea directory) but nothing works.


Please see above how to report it and get help.


I had this issue too. The latest community Idea was just stuck at "Scanning files to index" and did nothing. I could not even edit text or access menus.

Well, indexing really is damn slow, but at least I could make it do something.

The problem was the maven repository:

java.lang.RuntimeException: org.apache.maven.plugin.PluginResolutionException: Plugin org.apache.maven.plugins:maven-idea-plugin:[unknown-version] or one of its dependencies could not be resolved: Failure to find  org.apache.maven.plugins:maven-idea-plugin:jar: in http://*cannot-disclose*/maven/repository/maven-public was cached in the local repository, resolution will not be reattempted until the update interval of nexus has elapsed or updates are forced

at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolve(DefaultPluginDependenciesResolver.
at org.jetbrains.idea.maven.server.Maven3XServerEmbedder.resolvePlugin(

The repository *cannot-disclose* was visible only with VPN, and I started Idea without VPN.

Well, anybody would expect Idea to start rather then to crash silently even if the repository server is not available.

Just in case, the size of my employer's project is 1G in source, 13G after compilation.

BTW, I use the Community edition because the Ultimate edition is even slower. My employer does have a number of Idea keys.







Funny, im having the opposite error.

When i change a branch to a codebase having different versions in the pom.xml i get a lot of errors, that packages are not found. Even mvn clean install -U doesn't work. Only a reload of the maven project helpes in this situation.

It then starts the maven goal dependency:resolve, this does not help. After that runs a IntelliJ Task "scanning files to index" and only after that the project compiles again. Please fix.


Valerij Dobler

Please submit a new ticket to YouTrack with a description of your project and the idea.log (Help | Show Log in..., can be attached privately).


I disabled the Shared Indexes plugin and the endless rescanning and reindexing stopped.


Carlos Herrera That helped me too – I can't find any YouTrack tickets about it, though there are plenty about his issue in general.


Please sign in to leave a comment.