PHP tags being stripped out when pasting in 2019.1 EAP

Any one else seeing PHP tags being stripped out when pasting in the 2019.1 EAP?

Doesn't happen under all circumstances but definitely happens when pasting within HTML between braces? For example:

<?php
if ($foo) { ?>
     <h1><?= $foo; ?></h1>
     <?php
} ?>

Cutting "<?= $foo; ?>" from the above and pasting it back in exactly the same place, pastes only "$foo" and removes the tags. This is the same for long form "<?php echo $foo; ?>"

6 comments
Comment actions Permalink

Confirmed on PhpStorm 2019.1 EAP.

However, it is working fine on 2018.3.3.

Looks like, it happens during paste as <?= $foo; ?> is copied correctly to clipboard.

1
Comment actions Permalink

Just tried 2019.1 EAP #2 and the problem still occurs so had to roll back to 2018.3.3 again.

Can someone confirm if this is a bug or some weird, new expected behaviour? And if it is, how do I turn it off?!

I cannot see anything on the issue tracker either.

0
Comment actions Permalink

Scott, that's a new setting at File | Settings | Editor | General | Smart Keys > scroll to bottom (PHP) > Remove PHP Open/Close tags...

0
Comment actions Permalink

Update: that appears to be a bug. It would be great if you could submit this to our tracker at https://youtrack.jetbrains.com/newIssue 

0
Comment actions Permalink

I have reported it on YouTrack, please feel free to follow:

https://youtrack.jetbrains.com/issue/WI-45180

0
Comment actions Permalink

Thanks guys!

Quick Update: I tried changing the setting that Dmitry mentioned. It threw an exception (which I have submitted) when applied but it does now seem to work as expected.

0

Please sign in to leave a comment.