Mark Directory As... IDE forgets this

I keep marking my unit test folder as "Test Sources Root" but when I exit the project and return it never remembers it. 

Does anyone have any suggestions as to why this might be?

3 comments
Comment actions Permalink

Disable "Synchronize IDE settings with composer.json" at File | Settings (Preferences) | Languages & Frameworks | PHP | Composer

1
Comment actions Permalink

What part of the `composer.json` file is "synchronized" for IDE to forget this setting? Seems a bit odd to disable the synchronization completely, I'd rather fix my `composer.json` than to disable a useful setting.

0
Comment actions Permalink

Do you have any "autoload-dev" section in your composer.json file?

Please check this link as well:

https://blog.jetbrains.com/phpstorm/2017/07/configuring-with-composer-in-phpstorm-2017-2/

0

Please sign in to leave a comment.