PHPStorm snap installation won't start


Installed PHPStorm via snap.

1) When I try to run it from launcher, it just closes after a few seconds. 

2) When I try to run it from terminal, I get: "/ has 'other' write 40777."

My system is Ubuntu Mate 18.04.1 and below info about snap

snap --version
snap 2.37
snapd 2.37
series 16
ubuntu 18.04
kernel 4.15.0-45-generic

I've tried this suggestion but it didn't worked

Comment actions Permalink

I did further investigation and realised that I did massive mistake.

I've started to investigate and I found out that for some reason my root directory / had 777 permissions! Thankfully I quickly fixed it by doing

sudo chmod 755 /

After that fix PHPStorm launched without an issue.

Comment actions Permalink

Thanks for sharing the solution!

Comment actions Permalink

I had the same problem, the solution helped me to launch pycharm successfully, Thanks.

But, still I have no idea why the root directory was changed to 777 automatically


Please sign in to leave a comment.