Re: HTML page not loading when launching browsers from Intellij

Hi there,

I read through several other similar posts, and tried some of the suggested fixes, but I am still having some issues.

My problem is that I am using Intellij IDEA Ultimate 2018.2 and I trying to create and view a simple HTML page.  When I click on the browser preview buttons in the upper right corner of intellij, my browser opens, but I receive a 404 error.  Any help or guidance would be greatly appreciated.

4 comments

what does your `index.html` look like? Do you have <base href defined in it?

Also, looks like you have set up the built-in webserver to listen on port 8080 (Settings | Build, Execution, Deployment | Debugger, Port) - do you have any specific reason for this?

0

Hello Elena,

Thank you for your response.  Here is a snip of the index.html file.  I did change the port to 8080 from the default.  Do you need to be running a localhost server to view html docs in browsers from IntelliJ?  Sorry for the fundamental questions, I am very new at working with Intellij w/ respect to HTML.

Thanks,

Chris

 

0

>I did change the port to 8080 from the default.

what for?

>Do you need to be running a localhost server to view html docs in browsers from IntelliJ?

By default, HTML pages are served by IDEA built-in web server that is started automatically on IDE start

 

From your screenshot it looks as if you have just opened this file via File/Open, without creating a project? Serving such files doesn't work, see https://youtrack.jetbrains.com/issue/WEB-15729. You need creating a project first

0

Ahhh, OK, got it!  That makes sense.  Thanks for you help - it is much appreciated.

CHris

1

Please sign in to leave a comment.