2019.1 EAP git ssh connection timed out (behind proxy/firewall; built-in vs native ssh)

Answered

I am behind a proxy/firewall which intercepts all traffic. It took me already some time to setup everything so that my tools can communicate and do its job without a problem.

So that it worked flawlessly I used "built-in" ssh on the git-page. With "native" it didn't work for me. That was with version 2018.3*

With 2019.1 EAP this setting is not available anymore. So: what does "built-in" did exactly so that it worked or what should I do, so that it works again?

Any hint is highly appreciated. Will downgrade to 2018.3 for now.

OS: Windows 10; Intellij IDEA Ultimate EAP (191.4738.6)

4 comments

> With "native" it didn't work for me.

Does it work with the command-line git?

 

> With 2019.1 EAP this setting is not available anymore

It is still available but moved to the IDE registry - git.use.builtin.ssh

 

> what does "built-in" did exactly

Builtin is just a custom, rather limited implementation of SSH client. When Builtin is selected in settings, git is instructed to use it instead of the default ssh client. It has no benefits against native ssh, and basically, it looks like some configuration issue of the native ssh. Making native ss work in the command line should make it work in the IDE.

1

> Does it work with the command-line git?

No. I didn't configure much for the command-line yet. Just did now, but I don't like the idea of storing my user&password in the .gitconfig file... (and that didn't even suffice yet :-/ so probably have to play with sslVerify, ssl*-configs as well ... but will probably not, because... )

> It is still available but moved to the IDE registry - git.use.builtin.ssh

Thanks, that makes it working again! The built-in variant gets the proxy settings from Intellij correctly and as this now works I will stick to that :-) Except someone shows me that it's basically easier with .gitconfig than I am thinking ;-)

0

> Except someone shows me that it's basically easier with .gitconfig than I am thinking ;-)

Since you are using ssh, the proxy should be set for it, not in git config. There is no need to save any passwords in the config file. You should edit your .ssh/config. See https://stackoverflow.com/questions/19161960/connect-with-ssh-through-a-proxy

More generic information on git via proxy - http://cms-sw.github.io/tutorial-proxy.html

> and as this now works I will stick to that

Please note that builtin ssh does not support modern security keys formats and might failt to connect to servers in future if the key exchanges algorithms change. So I would recommend setting up native ssh connection and use it instead.

0

thanks for your suggestions... actually I already tried a lot regarding ssh and .ssh/config... (just didn't use the git-command-line ;-)) the .gitconfig-part was actually when I tried switching to https or git+ssh via https... the main problem I am facing is that many things are blocked and some downloads are even removed due to a possible virus signature... I don't even have the right tools at hand to setup the ProxyCommand via ssh correctly... (found connect.exe in mingw, but then it couldn't find the git-gui--askpass.exe :-( (there is a sh-variant, which doesn't get run; that is why I tried downloading the newest git ... with no success neither (virus...)) )... so: it is still the simplest possible solution to just stick with builtin-ssh... I also asked what the builtin variant actually does in the hope that I could reuse that for my ssh- or git-config ;-)

Maybe I will try again... but not in the next 1-2 months probably ;-) already tried too long...

0

Please sign in to leave a comment.