Storm keeps excluding my js folder automatically; cannot un-exclude via Prefs > Directories

I have a js folder inside one of my projects. Sometimes when I start up Storm, it reinitializes it as an excluded folder, forcing me to continually mark it as not excluded. However when I go into Preferences > Directories and navigate to the folder, then select it and try to deactivate the Excluded button option, it does not deactivate, but instead remains excluded.

How can I assure it no longer automatically gets excluded?

2 comments

Thank you Eugene, that was exactly what I needed to see. I am using webpack. I set my webpack output directory to a subfolder so that my source files would not be affected. Now PhpStorm only auto-excludes the build folder, and the source code is still indexed.

0

Please sign in to leave a comment.