DataGrip indexing entire home directory

Why is DataGrip indexing my entire home directory and running out of 2Gb of memory I allocated it?

 

 

5 comments
Comment actions Permalink

Have you pointed to this directory on the startup wizard as a "work directory"?

0
Comment actions Permalink

That could be the culprit but I don't see a setting to change it.

0
Comment actions Permalink

Please open the File tool window (Alt+2) and see what's there.

0
Comment actions Permalink

I see my home directory.

0
Comment actions Permalink

So that you can open, create, edit files there. And run them against data sources without opening.

If you don't need all this just detach it from the Files tool window. To do that press Delete

 

0

Please sign in to leave a comment.