Can't copy file from testData directory to the test project directory

Answered

Hi, i run to the problem while creating unittest for my IDEA plugin. I have a test class which extend from:
https://github.com/JetBrains/intellij-community/blob/master/platform/testFramework/src/com/intellij/testFramework/fixtures/LightPlatformCodeInsightFixtureTestCase.java

In this class, i create unitests. Thanks to the LightPlatformCodeInsightFixtureTestCase, i have fixture instance and i can call different methods from:
https://github.com/JetBrains/intellij-community/blob/master/platform/testFramework/src/com/intellij/testFramework/fixtures/CodeInsightTestFixture.java

In my plugin code i need to open file from project. Thats why i try to copy this file from testData directory to test project directory, so i can later open it with my plugin. I tried different methods like 'copyFileToProject()' but It seems like file is not copied. 

Test project value is for example like this: '/tmp/some_dir/light_temp.ipr'. But when i look to the /tmp/some_dir there are no files.

Where could be a problem? How should i copy files from testData directory to test project directory?

On a side note, testData directory should be configured correctly, since i can call method 'configureByFile()' and file will open in the in-memory editor. But it wont be copied to test project.

1 comment
Comment actions Permalink
Official comment

Please see http://www.jetbrains.org/intellij/sdk/docs/basics/testing_plugins/test_project_and_testdata_directories.html

 

"The files for the test project exist either in a temporary directory or in an in-memory file system, depending on which implementation of TempDirTestFixture is used.

LightPlatformCodeInsightFixtureTestCase uses an in-memory implementation [...]"

Please sign in to leave a comment.