debugger not working on PyCharm CE Errno 8] Exec format error: ?

Hi guys,

I've setup my local python3 project with an virtual environment, and Its all working fine and dandy, but I'm having a little trouble with the debugger.

When I hit the debugger button (little bug) I get this error:

/Users/user/.virtualenvs/app/bin/python /Users/user/.virtualenvs/app/bin/envdir /Users/user/work/foobarapp/.envdir "/Applications/PyCharm CE.app/Contents/helpers/pydev/pydevd.py" --multiproc --qt-support=auto --client 127.0.0.1 --port 56682 --file /Users/user/.virtualenvs/importer/bin/gunicorn -w 2 -b 127.0.0.1:5000 dispatch:app

Unable to run command /Applications/PyCharm CE.app/Contents/helpers/pydev/pydevd.py: [Errno 8] Exec format error: '/Applications/PyCharm CE.app/Contents/helpers/pydev/pydevd.py'

 

From what I've gathered it seems the pydevd.py script just freaks out when I'm trying to run it with envdir??

 

Tnx,

Tom

 

 

3 comments

Hi Tom,

You're probably right, your setup might be unsupported. Please provide screenshot of your run/debug configuration which causes the issue.

0

HI Andrey,

 

It seems to work only with environment variables without envdir....

Is using envdir possible for the debugger in PyCharm CE?

 

tnx,

Tom

 

0

Hi Tom,

I've never encountered a use case with envdir, and your launch string seems somewhat incorrect:

>/Users/user/.virtualenvs/app/bin/python /Users/user/.virtualenvs/app/bin/envdir /Users/user/work/foobarapp/.envdir "/Applications/PyCharm CE.app/Contents/helpers/pydev/pydevd.py" --multiproc --qt-support=auto --client 127.0.0.1 --port 56682 --file /Users/user/.virtualenvs/importer/bin/gunicorn -w 2 -b 127.0.0.1:5000 dispatch:app

To answer your question - no, we don't support envdir natively, but if you provide screeshot of your run configuration, we can try to see what's wrong and maybe provide some workaround.

0

Please sign in to leave a comment.