How to Hide/Remove Files from the Unreal 4 Engine

Answered

When I used Unreal 4 Editor to create a C++ Basic Code project with Starter Content (with CLion as the default source code editor), it creates the proper CLion project with all the source code. However, it also shows all the Unreal engine source files underneath the project folder. It also looks like it is taking CLion forever to build symbols....

Is there any way to not have them show up (the list of files is quite long)?

 

 

6 comments
Comment actions Permalink

>Isn't there a better way to organize them so hundreds/thousands of files don't show up under the Project window?

The only thing I can suggest is to create a user-defined scope (https://www.jetbrains.com/help/clion/scope.html) and select it as a View in the Project tool window.

1
Comment actions Permalink

Hi Ben!

The CMake project model is generated in such a way that CLion should index and build symbols not for the entire engine source, but only for necessary engine headers and source files.

However, we still recommend that you increase the amount of memory used by CLion, or at least check the real usage by switching on the memory indicator - Preferences/Settings | Appearance & Behavior | Appearance | Show memory indicator (the indicator will appear in the bottom right corner of the CLion window).

You can control what files are shown in the Project tool window using the View property - https://www.jetbrains.com/help/clion/project-tool-window.html#views. There are some predefined scopes views (Project Files, Problems, etc.), and also you can create user-defined scopes - https://www.jetbrains.com/help/clion/scope.html.

0
Comment actions Permalink

Hi Anna,

Thanks for the tip on the memory monitoring setting. However, my question is where do I look to see why they are included in the Project window. Sorry, still a little new to C++ and the CLion editor. Are they consider part of the source code for the project? If so, which file include them (I don't see them being included in CMakeLists.txt).

I have used IntelliJ IDEA for years and it has a module setting where it shows what libraries are included, source paths etc. CLion doesn't seem to have one.

Thanks, 

Ben

0
Comment actions Permalink

I assume those are engine headers and source files necessary for resolving symbols in your project and they are added to the fake target created for CLion needs to make all the intellisense possible.

You can select the "Project Source Files" in order to see which files are considered as project sources by CLion:

0
Comment actions Permalink

Thanks for being patient with me. I did what you suggested and they all show up (see screenshot). I know this is more of an Unreal issue - they generated the CLion project. Isn't there a better way to organize them so hundreds/thousands of files don't show up under the Project window?

0
Comment actions Permalink

Interestingly, when I am in the Project Source Files view and right-click on one of the source files, the pop-up menu shows "Open Module Settings". However, clicking on it doesn't seem to do anything.

BTW, I have 4 GB allocated for CLion. It is using about 2GB+. It started building symbols process again and took at least 15 to 20 mins. The memory usage never went above 2.5GB or so when it was doing that. 

0

Please sign in to leave a comment.