Menu dropdown overlapping

When the window is not maximized, the longer main menu drop-downs expand upward covering the top level menu item itself. Normally I wouldn't mind it too much since I generally use apps maximized, however with Material Theme UI it happens even when maximized.

Is there anything I can do about this?

5 comments
Comment actions Permalink

however with Material Theme UI it happens even when maximized

Is there anything I can do about this?

If updating the IDE and the plugin to the latest stable versions doesn't help, it makes sense to submit the issue to the plugin author's issue tracker:

https://github.com/ChrisRM/material-theme-jetbrains/issues

0
Comment actions Permalink

Material Theme UI is not responsible for the bug, the bug is simply more apparent with it. The GIF in my original post shows the bug with the default theme.

0
Comment actions Permalink

For some reason, I thought you don't consider this an issue when it's happening in the windowed state.

In the windowed state, does it happen only when the menu doesn't fit vertically or even if it does too?

0
Comment actions Permalink

It only happens when it doesn't fit vertically. Instead of the menu being positioned directly under the top level menu item and a scroll bar appearing, the menu just goes up (as seen in the GIF). Are you able to reproduce this behavior? I have changed very few settings from the default configuration (and nothing advanced).

0
Comment actions Permalink

I am. Personally, I'd prefer the current behavior over having a scroll bar on the menu, but that's my opinion, I get your point.

Here's the request for being able to scroll menus: https://youtrack.jetbrains.com/issue/IDEA-114971

I am not sure that it will cover the case when the window is not maximized, so probably it makes sense to create a new one asking to strictly forbid the menu go above the button: https://youtrack.jetbrains.com/newIssue?project=IDEA

And set it related to the one I posted.

0

Please sign in to leave a comment.