Phpstorm continuously requesting Default keyring

Hi,

i am trying to configure phpstorm 2018.3 with xdebug and ubuntu 18.04.2 keeps on throwing the 'default keyring' window. The set up i am trying to configure is the remote host one(writing code on a mounted folder from a remote virtual machine(php5.6)). 

I launch phpstorm with sudo.

Is there a solution on this? I have already tried various keyring solutions presented online but nothing worked since they all refer to the logged in user and not the root user. If you launch seahorse with sudo there is no option to create a default keyring option.

Any suggestions are more than welcome.

 

Thanks in advance!

 

Regards,

ioigoume

5 comments

Would it be possible to share a screenshot with this window?

Also, I was wondering if you could share "File | Settings | Appearance & Behavior | System Settings | Passwords" settings windows screenshot as well.

 

Thanks!

0

Hi Vasiliy,

well i can not provide a screenshot from keyring since as soon as the default keyring pops up i can not use the print screen key. 

 

File | Settings | Appearance & Behavior | System Settings | Passwords => In native Keychain is checked. Only this from this tab

 

The problem is not only the keyring window but the fact that if i try to give a password a couple of times then ubuntu crashes and i have to restart by hitting the power button. I do believe that starting phpstorm with sudo might have to do with the whole problem.

 

Thank you.

0

Hi,

some more info on this problem. 

I found out that even though i get the Default keyring window triggered by the phpstorm the connection over ssh tunneling from my local pc to the remote server works. This makes me think even more that the problem might be that i start phpstorm with sudo.

Also, the Default keyring window launches as soon as i press the debug(beatle) button on the toolbar. Then, even if i stop all debug, i can not get rid of the pop up.

 

Thank you.

0

We don't recommend starting PhpStorm with sudo, but since you do that, it makes sense to switch the storage from the local keychain to KeePass, it should do the trick.

0

Hi Eugene,

thank you for the hint. Now it is ok. Unfortunately there are some occasions that i do need to use phpstorm with root privileges.

 

ioigoume

0

Please sign in to leave a comment.