Cannot see Ruby SDKs

Answered

I am using Ultimate 2018.3 and have the Ruby plugin installed and enabled. Running on OSX High Sierra

I have also install RVM version 1.29.7 and have installed the latest version of ruby though that, being v2.6.0p0

My reading of the documentation is that I should be able to see that Ruby automatically in my SDK list with Project Settings. I don't. I've tried to add it directly by adding a new SDK and pointing it at the ruby directory within the .rvm folder but that is just not recognised.

Am i not configuring something correctly or is this not supported by Intellij anymore? 

3 comments
Comment actions Permalink

Hello Steve,

could you please check that both Docker Integration and SSH Remote Run plugins are enabled? If not then please enable them and restart IDE, how does it go in this case?

0
Comment actions Permalink

Hi Olga,

 

I did not have SSH Remote Run enabled.  Enabling it sorted the problem, I can now see the rvm ruby installs as expected.

Many thanks for the quick reply and excellent help.

Steve

0
Comment actions Permalink

Thanks for checking, we have a corresponding issue for improving the current behaviour: https://youtrack.jetbrains.com/issue/RUBY-20288

0

Please sign in to leave a comment.