Terminal integration broken for custom prompt

Hi,

 

I am using Webstorm 2018.3.5. I use a custom terminal prompt for git directories that is broken since last two builds.

Here is screenshot of my terminal window:

and this is for webstorm:

 

Notice how the git branch name (develop) is missing from terminal prompt. There is also a dirty status if the git directory is dirty.

This was working perfectly until the last two release of Webstorm. I am using [GitAwarePrompt](https://github.com/jimeh/git-aware-prompt)

7 comments
Comment actions Permalink

Please provide your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) and screenshot of terminal preferences page (Settings | Tools | Terminal)

0
Comment actions Permalink

Here you go

 

0
Comment actions Permalink

It does not allow me to attach log files.

[Edit] I uploaded the log file here: https://www.dropbox.com/s/dw10lfxpmvzkq1m/idea.log?dl=0

0
Comment actions Permalink

Does disabling Shell integration option in Terminal settings help?

0
Comment actions Permalink

disabling Shell integration fixes the issue. Thanks a lot. I am not sure why this was selected. What does this option do?

0
Comment actions Permalink

As it's written in Help, if this option is selected, the terminal first loads a custom rc config file (located in the terminal folder under plugins of WebStorm distribution) which provides an additional set-up, like key bindings, and then the user's rc file.

0
Comment actions Permalink

Thanks for quick response and explanation. You had been a great help.

0

Please sign in to leave a comment.