Stored Procedure and view does not show up in db explorer tree


I am using DataGrip 2018.3 to access a SS 2017 database.

There is 1 view and 1 stored procedure I noticed that do not show in DG but exist ( and can be viewed in SSMS).

I've tried "Sync" from the toolbar and File menus.

I've also tried to "Invalidate and Restart".

None of these help. 

This rather annoying and raises my suspicions that what DG is provided me may not be 100%  accurate or reliable.

The workaround is to use SSMS which *is* 100% accurate and reliable.


Is there a fix for this problem?






Hi! Does Forget Chached Schemas and then Sync helps? 

ÐаÑÑинки по запÑоÑÑ datagrip forget cached schemas


I ran into this too


Alan, a screenshot please


Let me rephrase:  I had a similar experience wherein I did not see stored procs in the DB tree view.  I then found this thread which suggested "Forget Cached Schema" and that worked to fix the issue for me.  So I do not consider this a bug or issue, just a minor nuisance. So I no longer have the screenshot.


Anyway, it's not ok. What database it was?


bruce radtke,

Is it possible for to update DataGrip to 2020.1 and try to reproduce your issue?


Alan Berezin1,

Could you specify DataGrip version you work with?


It was a sqlserver2019 database and I was on the DataGrip version just previous to 2020.1 at the time.  I have since upgraded to 2020.1 .  I haven't seen the problem but I have serious doubts as to how I could repro it.  I will definitely report it in this thread if I see it again.


I use oracle in Datagrip, and not show procedure too


Please follow the troubleshooting guide at
Does it help?
If no, please share the screenshot of "Test Connection" result like that:
And chosen schemas to introspect here:


Please sign in to leave a comment.