Changing version of type definitions

I have a JavaScript project with a particular node module installed. This module is an older version (will update but can't right now). In the meantime, I want to get a type definition file for this version. I've tried adding it as a library from Settings -> Languages & Frameworks -> JavaScript -> Libraries. But this only allows me to download the latest type definition file. I tried using `npm install @types/` with the correct version, which successfully downloads the correct type definition, but WebStorm is not associating this with the node module. Any help?

1 comment

>I tried using `npm install @types/` with the correct version, which successfully downloads the correct type definition, but WebStorm is not associating this with the node module. 

This should work. Please can you share a sample project that shows up the issue?

0

Please sign in to leave a comment.