Unexpected result with embed terminal and gulp run

Hello,

As I commented in my last thread I use Windows 10 with Cgywin as a terminal for PHPStorm, the terminal works well under PHPStorm even install some utilities of cgywin as the utility 'rf' to delete files like linux does, the problem is that when I run it through task 'RUN' with GULP does not recognize the command, but when I run it directly on the terminal, it works, so what is happening? Any solution to use the Gulp tab?

3 comments

PhpStorm doesn't use any shells to run Node through run configurations, it's being run directly.
As your Gulp task requires using rf command that is only defined when running your shell, try to configure Node.js interpreter in your Gulp run configuration so that it points to a wrapper script that runs node.js interpreter under the hood. It can be a shell script that starts your shell and then calls node.js interpreter, passing parameters to it...

For example, for bash:

@echo off
"C:\Program Files\Git\bin\bash.exe" "\path\to\bash-node.sh" "%*"

where bash-node.sh is:

#!/bin/sh
"C:/Program Files/nodejs/node.exe" "$@"
0

Thanks so much, but you can help me to do it with Cgywin and the only information I can give you that the code I use to embed the terminal in PHPStorm is:

"c:\cygwin64\bin\sh" -lic "cd ${OLDPWD-.}; bash"

also try with:

@echo off
"c:\cygwin64\bin\bash" -l E:\\www\\config\\bash-node.sh %*

but you still don't recognize the rf command

0

Finally I solved it by putting in the system variable 'PATH' the path to Cygwin bin without the need to create a batch file 

c:\cygwin64\bin
0

Please sign in to leave a comment.