Cannot get Django test cases to run.

Hi guys - 

I cannot get my django test settings to run, I had them working before but lost my settings.

 

I can run my django server just fine without issue. My test cases refuse to run and give me the error:

django.db.utils.DatabaseError: ORA-00955: name is already used by an existing object

 

This is the same error I get if I run my test cases on the dev. server "python manage.py test --keepdb".

However if I run "python manage.py test --keepdb --settings=xxx.settings.test" everything runs fine.

 

How do i get the tests to correctly run in pycharms the same way?

Please see screenshots. We have a professional license.

Dev:

 

Test Settings:

 

 

5 comments
Comment actions Permalink

not a very active forum i suppose.

0
Comment actions Permalink

Hi,

I googled that error, but every occurrence I find is related to Django/code/Oracle DB configuration:

https://stackoverflow.com/questions/51712015/django-migrate-command-throwing-ora-00955-error

https://groups.google.com/forum/#!topic/django-users/lVS24BGFouo

https://code.djangoproject.com/ticket/13565

 

Please try running the same command from outside of IDE to determine if the issue is IDE-specific.

0
Comment actions Permalink

It's IDE specific, I can run the tests with: python manage.py test --keepdb --settings=bbb.settings.test in the console.

0
Comment actions Permalink

Looking at your second screenshot, have you tried enabling the "custom settings" checkbox and specifying the settings file there, instead of the options field? Is result the same?

0
Comment actions Permalink

It is, which is what makes this weird.

 

I'll just keep using my ssh session i suppose.

0

Please sign in to leave a comment.