Cannot run idea.sh from terminal

Answered

I carefully downloaded IntelliJ Idea following the instructions on the IntelliJ site and after moving to the /opt directory, I tried to start it using idea.sh from the terminal but nothing happened.  Nothing.  Please help.

4 comments

Hello Dan,

Why did you move it to /opt directory? Does it start from downloaded location? Have you tried to run it with sudo?

 

0

Thank you for responding.  I have moved it to the /opt directory with the same result and it also does not start using sudo.  I have also re-installed again in an attempt to ensure that it wasn't an issue with the download.  Same result.

0

Dan,

Could you please provide screenshot with terminal after reproducing? Also please check process explorer for any IDEA related items.

 

 

0

It is a bad idea to run IDEA using sudo as all the config and temp files will be owned by root.

Which file did you download?

Try downloading the tar file

wget https://download.jetbrains.com/idea/ideaIU-191.6707.31.tar.gz
tar -xf ideaIU-191.6707.31.tar.gz
cd idea-IU-191.6707.31/bin
./idea.sh

Once it works there you can then try moving it to another directory.

 

 

0

Please sign in to leave a comment.