Alt-gr not working on PyCharm


Fellow programmers,

I am entirely unable to use the ALT-GR key, or even the CTRL+ALT combination into PyCharm, whenever I try to use it unless I'm in the terminal, where it works.

This sounds very strange to me and it's sending me crazy, because I'm unable to type any bracket, having an Italian keyboard.  


Thank you in advance,

Take care.

Official comment

The problem is known, please upvote and follow for updates.


See this comment for a temporary workaround

I have the same issue and I don't know how to fix it.


I have got the same issue. I have got an Italian keyboard and I need the ALT GR key..


Please update to 2019.1 and see if problem remains.


Hi Sergey,

Yes I have got the issue with the last version of 2019.1.

If I return to 2018.3 version, I have not got this type of problem.


Hi Sergey,

It has already been done.
Precisely, the problem appeared after the 2019.1 update;


I'm sorry but I already have 2019.1 version :(


Same issue here after upgrading from 2019.1 EAP. No more Python coding w/o a chance to enter [] or {} on my keyboard. Sergey, could you please elaborate on "switching IDE to run under 1.8 JDK"?


Same issue here with french keyboard since 2019.1 EAP


Same issue here with french keyboard after updating PyCharm. Resolved by changing JDK embeded in PyCharm to system JDK :

PyCharm -> Help -> Find Action... -> Entrer "switch" to find "switch IDE Boot JDK" :


EDIT : Unckecked "" in PyCharm registry works. Thanks Josip !


EDIT 2 : Updated PyCharm today, ALT+GR doesn't work anymore, had to check "" + restart to make it work.


I confirm that swiching to JDK1.8 solves the problem.



Problem solved with the IDE Boot JDK switch, thanks for helping us!


Updated today to PyCharm 2019.1. Had the same problem and fixed it by changing registry

In PyCharm click Ctrl + Shift + A. Then write registry and click on it. Find and uncheck it.

Then it should work (at least it did for me)


Unchecking also works for me with JB JDK1.11


Unchecking works like a charm ... Sweet!


Thanks Josip Komljenovic

Unchecking in Registry works for me


If anybody else is still stuck on this, for me unchecking didn't work, but unchecking did the trick.


Another one with the same problem after updating PyCharm. The registry fix worked :) Thanks!


Hi :-)! The switch to Java 1.8 fixed for me too. Thanks for the solution!


Latest PyCharm update (PC-191.6605.12) fixed the problem "for good".


I am a bit confused. I have the latest PyCharm Version and sometimes "alt gr" stops working during a session. What are the defaults in the registry? Assuming that non default values are highlighted in bold blue font, I have:

  1. checked (default)
  2. checked (non default)

If I uncheck the force option, alt gr stops working.


Version info:

PyCharm 2019.1.1 (Professional Edition)
Build #PY-191.6605.12, built on April 3, 2019
JRE: 11.0.2+9-b159.34 amd64


Like Alexlampe I had to check It doesn't matter what I set to be; therefore I left it at the default (checked) setting. Same version but community edition.


Thx @Elifgsavukcam 

All the others didn't work, but yours did.

Just check and that worked instantly without restarting anything


Hello, switching to Zulu OpenJDK 1.8 also solves the problem in macOS Mojave.


It seems the issue resurfaced in IntelliJ 2020.1. I wasn't able to make it work by changing the registry values.

Windows 10, Hungarian keyboard


Martin I am on 2020.1 (build @PY-201.6668.115 of April 7, 2020) and I can confirm Alt-Gr is working fine on my Windows 10 with Belgian Azerty keyboard.


Please sign in to leave a comment.