Issues building my plugin with 2019.1 RC


I just installed the 2019.1 release candidate and tried to build my plugin. I'm receiving three compilation errors (shown with the corresponding lines of code):

Error:(628, 69) java: cannot access kotlin.jvm.functions.Function1
class file for kotlin.jvm.functions.Function1 not found

String[] saveAllActionIds = modifiableKeymap.getActionIds(saveAllKeyStroke);

Error:(733, 73) java: cannot access kotlin.jvm.functions.Function2
class file for kotlin.jvm.functions.Function2 not found

String[] saveAllActionIds = modifiableKeymap.getActionIds(saveAllKeyStroke);

Error:(20, 14) java: cannot access kotlin.Lazy
class file for kotlin.Lazy not found

super(...); // from a subclass of ConfigurationTypeBase

My plugin is written in Java 8 and has no direct dependency on Kotlin. I've tried to add kotlin-stdlib*.jar to the plugin SDK which is where these classes are found, but that doesn't seem to make a difference.

Any idea what's going on here and how to resolve it?

UPDATE: I'm able to build from the command-line using the javac2 ant task with the same classpath as what I should be using in the IDE, so this seems to be something specific to the IDE's integrated compiler.


Please sign in to leave a comment.