DataGrip Git4Idea plugin dependency

Answered

Hi,

I have a plugin with following xml: https://github.com/zielu/GitToolBox/blob/191-develop/GitToolBox/src/main/resources/META-INF/plugin.xml

I depend on APIs exposed by Git4Idea so following dependencies are declared:

<depends>com.intellij.modules.platform</depends>
<depends>Git4Idea</depends>

With this all products are compatible with exception of DataGrip which is marked as not compatible because of Git4Idea dependency. I noticed that in DG Git Integration is not bundled, but must be downloaded from Marketplace and then my plugin can be installed manually.

Is there any way to make my plugin detected as compatible with DG ?

 

2 comments
Comment actions Permalink
Official comment

Hi,

DG is set as compatible with Git4Idea on the plugin repository side now, and therefore your plugin is compatible with DG as well.

Thank you!

Comment actions Permalink

Works as expected, thanks!

0

Please sign in to leave a comment.