Stepping whilst debugging sometime runs

On Numerous occasions I have been debugging and using F10 to step, sometimes F10 causes the program to continue as if I have pressed F5. This proves very annoying especially when I've spent a good few minutes tracing to a certain point only to find the next press of F10  continues the program and I have to restart the whole process all over again and hope that this time it doesn't continue. It's sometimes that bad that I use Webstorm for the superb editing environment and then use Visual Studio to debug.

Does anyone else suffer from this? Is it a known issue that still needs (or is currently being) looking at, as it currently spoils a great IDE.

 

 

6 comments

please try disabling "Do not step into library scripts" ( Settings | Build, Execution, Deployment | Debugger | Stepping) - does it make any difference?

0

Thanks for that Elena, I'll give it a go and get back to you 

0

Tried with this enabled and disabled, also tried it with "Do not step into script" enabled and disabled, I get the exact same behaviour, it still occasionally continues when trying to single step whilst debugging

0

Can you share a sample project that can be used to recreate the issue?

0

Thanks for getting back to me Elena,

 
I have spoken to my manager and providing you (JetBrains) are prepared to sign a None Disclosure Agreement I can zip up my source and send it to you.
 
Regards
Sean
0

Sure we can sign it. Please create a new support ticket (https://intellij-support.jetbrains.com/hc/en-us/requests/new) to keep everything private

0

Please sign in to leave a comment.