I can't find where the xdebug.remote_host is set in PHPStorm

Many months ago, I had PHPStorm configured to use Codeception and created several tests. I am now getting back to that code and testing. I can run the tests but they fail with a 255 error code. I am unable to debug them for, I believe, a misconfiguration.

When I go to run my tests suite, PHPStorm issues the following command that I can see in the testing console:

[ssh://futurest@exportedfs.com:22]:/usr/bin/php -dxdebug.remote_enable=1 -dxdebug.remote_mode=req -dxdebug.remote_port=9000 -dxdebug.remote_host=192.168.1.4 /home/user1/.phpstorm_helpers/codeception.php run --report -o "reporters: report: PhpStorm_Codeception_ReportPrinter" --no-ansi --no-interaction -c /home/user1/codeception.yml tests/api/hmMultiModsTestSuiteCest.php

This is the problem: -dxdebug.remote_host=192.168.1.4

My network has changed since I last ran these tests. My local machine (which is the one I want to debug on) is NOT 192.168.1.4. It is 192.168.1.3. 192.168.1.4 is now my Google Home.

I cannot find the 192.168.1.4 address ANYWHERE. I've been through all the configuration panels I could think of. No IP addresses are hardcoded in the Preferences panels. I've been through the .idea/ files and various *.yml files. The settings in /etc/php/d/xdebug on my VM is correctly point to 192.168.1.3.

Where/how do I tell PHPStorm to pass the Xdebug remote host as 192.168.1.3?

 

1 comment

Hi there,

AFAIK it's autodetected.

Anyway, you may pass -d params in PHP Interpreter settings and it will override autodetected stuff.

P.S. Alternatively you may disable "Settings (Preferences on macOS) | Languages & Frameworks | PHP | Debug | Pass required configuration options through command line (still need to enable debug extension manually)" option so IDE will not be adding those extra -d params (and PHP will use whatever you have configured in your php.ini).

0

Please sign in to leave a comment.