Debugger Console Encoding issue

Answered

The Debugger Console is using a wrong encoding. I have set.

-Dconsole.encoding=UTF-8
-Dfile.encoding=UTF-8

However, the issue persist.

1
13 comments

Are you using a custom font (Preferences | Appearance & Behavior | Appearance | Use custom font)? Or maybe custom font for the console (Preferences | Editor | Color Scheme | Console font)?

2

You were right, was the font. I was using Fira Code https://github.com/tonsky/FiraCode

I have changed back to Menlo and now is displaying the text properly.

2

Hi.

Have you restarted the IDEA after changing VMoptions? Also could you please provide idea.log (Help | Show log...).

0

Yes, I have. Also I have Invalidate Caches and restart.

Here is the link to the log file.

https://drive.google.com/file/d/1OeUgGTEgMRiFZFmAnB94ECzD10fYEWWY/view?usp=sharing 

0

Could you please provide an example of the project where the problem reproduce?

0

It's on all projects, even when I start a new project from a template.

The problem is on IntelliJ IDEA 2019.1 Beta

IntelliJ IDEA 2019.1 Beta (Ultimate Edition)

Build #IU-191.6183.20, built on March 14, 2019
IntelliJ IDEA EAP User
Expiration date: April 13, 2019
JRE: 1.8.0_202-release-1483-b39 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.3

I have tried to replicate the issue on the stable build, and its working fine there.

0

I set it like this,but still error

 

0

@Xuzqyoung  Maybe you should set the fallback font to a more complete font set, say the MS YaHei UI.

0

I can not output  like this 【】 

0

@Xuzqyong  Can you attach the screenshots of your errors window and fallback font settings?

0

I’ve just run into this issue. After a little trial and error, here’s what I found:

  • The only monospace font on my system with this issue is JetBrains Mono (oops)
  • Copy/pasting the corrupted text into the main editor ‘corrects’ it
  • Ligatures enabled/disabled makes no difference
  • The patched Nerd Fonts version of JBM does not have this issue
  • Fira Code works OK but individual weighted versions (Fira Code Light/Medium/Retina) do not, instead displaying a random serif font and ignoring the fallback

Any ideas?

 

WebStorm 2019.3.4
Build #WS-193.6911.28, built on March 18, 2020
Licensed to <redacted>
You have a perpetual fallback license for this version
Subscription is active until <redacted>
Runtime version: 11.0.6+8-b520.43 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.15.3
GC: ParNew, ConcurrentMarkSweep
Memory: 8108M
Cores: 12
Registry:
Non-Bundled Plugins: BashSupport, Gitflow, com.intellij.database, com.jetbrains.darkPurpleTheme, com.markskelton.one-dark-theme, com.paperetto.dash, com.wakatime.intellij.plugin, intellij-clock, izhangzhihao.rainbow.brackets, lermitage.intellij.extra.icons, org.intellij.plugins.postcss, org.toml.lang, org.rust.lang

0

Please report at https://youtrack.jetbrains.com/newIssue?project=IDEA with a sample project to reproduce and a screenshot of the issue.

0

Please sign in to leave a comment.