Disable Typescript Compilation by Default [2019.1]


How I can disable Typescript compilation (almost useless and broken) for every project? This is enabled by default and when I open new Typescript project Idea starts to compile typescript without any questions and I need to turn it off in every projects every time! In setting I have only 'For current project option'. How I can mark it 'Disabled by default?

In versions before 2019.1 I didn't faced with this problem.


Edit: Moreover I even can't turn it off for project! This option is turned on by itself every relaunch of idea! See screen-cast here:




Option is disabled by default on my machine. Could you please attach ".idea\typescript-compiler.xml" file from your project and "idea.log" ("Help | Show Log in...") after restarting IDE ?



Hi, I experimented a bit with clean install of Idea and found the reason of this strange behavior. Looks like the root cause of my problem was in TypeScriptExecutor plugin. When I disabled it 'Recompile on changes' option started work fine. Thanks for help


We're having the same issue even without the above plugin. We are unable to turn off Transpiling.


do you mean that the option gets re-enabled on each IDE restart? is the issue specific to certain project (i.e. can you reproduce it in a new project)? please recreate the issue and share your idea.log (upload it to some file server and provide a link)


Please sign in to leave a comment.