ESLint errors not shown in editor window

I want to enable highlighting for linting errors for my TypeScript project using ESLint. I can't figure out how to do this. This screenshot shows the console output of "eslint --ext .ts .", index.ts in the editor window which does not have the errors highlighted, and the settings I'm using:

 

Here is the project: https://gitlab.com/MakotoE/js-test.

Version info:

WebStorm 2018.3.5
Build #WS-183.5912.23, built on February 26, 2019
Licensed to Makoto Emura
Subscription is active until October 25, 2019
JRE: 1.8.0_152-release-1343-b28 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.9.0-8-amd64

I looked at https://www.jetbrains.com/help/webstorm/eslint.html but it didn't help. How do I enable linting? Thank you.

1 comment
Comment actions Permalink

Sorry, but I can't access https://gitlab.com/MakotoE/js-test - is returns 'forbidden'.

When checking if ESLint should be run on a .ts files, WebStorm 2018.3 analyzes the root config statically to see if it includes the following plugins:

  • "parser":"babel-eslint" or
  • "parser":"typescript-eslint-parser" or
  • "eslint-plugin-typescript"

Since config files can extend others and we don't currently analyze the whole chain statically, it is also possible to add specific extensions via eslint.additional.file.extensions Registry property (for example, set it to ts,tsx): in Help | Find Action..., type registry to locate it, then search for eslint.additional.file.extensions  key and change its value accordingly

 

Since 2019.1, configuration will be evaluated in runtime, plus more plugins/parsers will be checked (all packages listed in https://github.com/typescript-eslint/typescript-eslint#about should work)

2

Please sign in to leave a comment.