My Program isn´t running with the "Run" command but with "Debuggging"

Answered

I have written a little Program (basically just: print("Lol")). But the "Run" command does absolutely nothing. It just shows: "Process finished with exit code 0". However if I try the command "Debug" it shows:

Connected to pydev debugger (build 183.5153.39)
pydev debugger: process 8544 is connecting

Lol

Process finished with exit code 0

Now of course some Questions show up in my head like: "Why?" or "How could I possibly fix this?". And I´d really like to have these Questions answered. So if anyone knows a solution, feel free to contact me.

Sincerely Austin.

 

 

Oh wait my Name is Lucas... but Oh well...

 

 

If anyone didn´t get that reference feel free to check out the Youtube Channel "The Game Theorists".

4 comments
Comment actions Permalink

So... What I´ve found out by now: It´s a failure of the print and input command... so I used "input("lol")" and there still was no text but I could actually input something... buttttttttttt that was it already... What The Actual Fuck

0
Comment actions Permalink

Please attach a screenshot showing the whole console output and another one with your Run/Debug configuration (Run | Edit Configurations...).

0
Comment actions Permalink

Sergey

I have the same problem.  Push debug button and it just runs.

 

 

I cannot post console output because it is proprietary code from university for an assignment.  

But it's the same thing I get when I run.  

Hold on, I can't set a breakpoint on return statements.  That is really stupid.  I set a breakpoint elsewhere and it works now.

I want to set them on return statements so I can check everything is okay in each function.

Good free software, not more.  Thanks.

 

 

0
Comment actions Permalink

Yeah I figured it out by now. Are you using an anti virus software like Comodo?

0

Please sign in to leave a comment.