DataGrip: com.intellij.execution.ExecutionException: SSH: Failed to load identity file

Answered

I have a private key in ~/.ssh/id_rsa

I can confirm that I can ssh from the terminal

I am trying to setup an SSH tunnel in data grip, and when specifying the Private Key File, I get the error:

com.intellij.execution.ExecutionException: SSH: Failed to load identity file

16 comments

I have even tried the fully qualified path /Users/myusername/.ssh/id_rsa with no luck as well

0

@Sheehan

Could you email Vasily.Chernov@jetbrains.com me IDE logs and specify your id-rsa type?

A workaround mentioned in https://youtrack.jetbrains.com/issue/PY-33798 may help you.

0

I'm having the same issue. My key works in other applications and via terminal. The workaround didn't work for me.

0

@Developer

Could you email Vasily.Chernov@jetbrains.com me IDE logs and specify your id-rsa type?
What workaround did you use?

0

I'm also getting this same error, is there a way of dealing with this yet?

 

0

Hello, I got the same error.

I read the suggested workaround, but still no clue. 

Thank you.

0

@ Rkukuh 

You need to use `OpenSSH config and authentication agent` option and to use ssh agent as a workaround.

 

 

0

Hello, I got the same error.

can you give me a beautiful solution?

0

@858299224

Could you specify your DataGrip version and specify your private key pair encryption type?

 

0

I'm having the same issue, i'm using DataGrip 2019.1.4 and a rsa 2048 key

0

@galla,

Make sure you load ssh key into auth agent.

If there is still the issue, could you try to reproduce it with the latest DataGrip 2019.2 EAP and specify your case in https://youtrack.jetbrains.com/issue/IDEA-216202?

 

 

0

@vasily: I have just tried to use on 2019.2 EAP. And it worked. Don't get

com.intellij.execution.ExecutionException: SSH: Failed to load identity file and can connect to DB via ssh tunnel

0

@Bao Doan Ngoc,

Cool, there are a lot of improvements in SSH subsystem in the coming DataGrip 2019.2 release. Stay tuned and up to date.

0

 

Hi, it works on the 2019.2.1 version.

 

Tks

0

Please sign in to leave a comment.