php-cgi not found

I have phpstorm 2018.3 and get this error repeatedly when trying to click on a browser icon. My php version is 7.2.15. The full error (bottom right) says this:

Please ensure that configured PHP Interpreter built as CGI program (--enable-fastcgi was specified)

I have clicked on the link in this error to mark php 7.2 as my choice for both options.
1 comment
Comment actions Permalink

This message means that your interpreter lacks the php-cgi module, and we can't execute php -s

Usually, it's the case for macOS, is it the OS you're using?

If so, please check this SO thread: https://stackoverflow.com/questions/47680832/php-cgi-not-found-in-phpstorm-resulting-in-502-bad-gateway

0

Please sign in to leave a comment.