Webstorm 2019.1 high cpu load after long time idling

After upgrading to Webstorm 2019.1 I have the problem that when I keep it open over the day (mostly idle in the background) in the afternoon the CPU will spike up incredibly, making the OS slow and letting the fan sound like a helicopter. I need to force quit it over the activity monitor, a normal quit is not possible.

  • WebStorm 2019.1
    Build #WS-191.6183.63, built on March 21, 2019
    JRE: 1.8.0_202-release-1483-b39 x86_64
    JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
    macOS 10.14.4 (18E226)
13 comments
Comment actions Permalink

Please try taking CPU snapshots when the issue occurs (https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems) and provide them along with your log folder zipped (Help | Compress logs and show in Finder)

0
Comment actions Permalink

I seem to not be able to tick that option - it's greyed out...

Plugin is enabled though..

0
Comment actions Permalink

You need modifying vmoptions to enable CPU profuiling, please see (https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems for instructions

0
Comment actions Permalink

I have the same problem. Can't take CPU snapshot because IDE doesn't respond, but get dump from

jstack -l <PID>

https://drive.google.com/file/d/1ZKoCNb5dcorShaBOHXcV4UiiSSMYXEOk/view?usp=sharing

WebStorm 2019.1
Build #WS-191.6183.63, built on March 21, 2019
Subscription is active until January 29, 2020
JRE: 1.8.0_202-release-b1538 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.4

0
Comment actions Permalink

I had the same issue, switched back to 2018.3, waiting for a fix.

0
Comment actions Permalink

Having the same issue 

0
Comment actions Permalink

Same Issue here. Still a problem in Version:
WebStorm 2019.2.3
Build #WS-192.6817.13, built on September 24, 2019
Runtime version: 1.8.0_171-b11 amd64
VM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1967M
Cores: 8

Could not snapshot the problem, because as soon as I select the DropDown Menu like File, Edit, View,... CPU usage goes down. Was able to spot something with the Java VM Thread View:

After a few minutes this Thread starts :AWT-EventQueue-0 2019.2.3#WS-192.6817.13 WebStorm, eap:false, os:Windows 10 10.0, java-version:Oracle Corporation 1.8.0_171-b11 2019.2.3#WS-192.6817.13 WebStorm, eap:false, os:Windows 10 10.0, java-version:Oracle Corporation 1.8.0_171-b1
and causes high CPU usage.

0
Comment actions Permalink

>Could not Snapshot the problem, because as soon as I select the DropDown Menu like File, Edit, View,...

you can turn sampling on to auto-enable profiler on application start (https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems#capture_slow_startup_2019_1), start the IDE, wait till the indexing completes, reproduce the issue and then close the IDE. CPU snapshot file will be saved automatically after your close the IDE into your HOME/snapshots directory with the .snapshot extension.

Your log folder (Help | Compress Logs and Show in Explorer) would be also helpful

0
Comment actions Permalink

I uploaded the snapshot file to https://uploads.services.jetbrains.com/

WS-192.6817.13_Sebastian_07.10.2019_12.56.41.zip

0
Comment actions Permalink

looks related to https://youtrack.jetbrains.com/issue/JBR-1820; please file a ticket to youtrack, https://youtrack.jetbrains.com/issues/IDEA, attaching CPU snapshots and log folder zipped

0
Comment actions Permalink

Switching the Runtime Java Version to 11 solved the problem for me.
https://intellij-support.jetbrains.com/hc/en-us/articles/206544879

0

Please sign in to leave a comment.